Redes-Linux.com
Esta página esta optimizada para ser visualizada tanto en navegadores gráficos, como en navegadores de texto.
 
Buscar en:


 
El Servidor
Current bandwidth utilization 0.01 Mbit/s
Ancho de banda utilizado
 
Redes-Linux
 
Tip Today by ugu.com
 
Más cosas
 
Conóceme
   [Registrarse]  [Editar Perfil]  [Editar sus Preferencias]  [Buscar]
[Mensajes Privados]  [Lista de miembros]  [preguntas]  [Entrar]
Redes-Linux Forum Index » » Redes en GNU/Linux » » Samba como PDC & XP
Autor Samba como PDC & XP
Mai


Registrados: Sep 26, 2002
Mensajes: 7
Publicado: 2002-09-30 19:49   
tengo problemas al tratar de validar usuarios XP al dominio samba(PDC).

*por parte de Win XP:
cada vez q trato de cambiar los usuario(clientes) XP de workgroup a dominio
(q es el sever con samba), me pide una nombre de usuario y contrasena q se pueda unir al dominio...mmmm....mejotr explico paso a paso para q quede clarito.

primero voy a My pc->propiedades->nombre de equipo->cambiar y cambio de grupo de trabajo a dominio....al aceptar eso me pide una contrasena valida para unirme al dominio, use la de un usuario y la de admin user= aleja...que tiene privilegios de root....y no se puede
...me dice error al intentar unirse al dominio "hogar" acceso denegado.
(si pongo un usuario no valido , me dice q no lo reconoce..eso es algo!)

como lo de arriba no me resulto comenze por My pc->propiedades->nombre de equipo->id de red....segui todo paso por paso hasta q llege a un punto en que me dice: windows no puede encontrar una cuenta para el equipoen el dominio.(yo ya las tengo creadas , las hice asi :
useradd -d /dev/null -s /bin/false endor$ y paraagregarlas a samba: smbpasswd -a -m endor )
por lo q creo q esta bien!!!

EN EL SERVER ME ARROJA ESTOS LOG AL TRATAR DE CONECTARME:

[2002/09/30 11:57:11, 0] rpc_server/srv_samr.c:api_samr_set_userinfo(670)
api_samr_set_userinfo: Unable to unmarshall SAMR_Q_SET_USERINFO.
[2002/09/30 11:57:11, 0] passdb/pdb_smbpasswd.c:pdb_getsampwrid(1416)
unable to open passdb database.
[2002/09/30 11:59:24, 0] rpc_server/srv_samr.c:api_samr_set_userinfo(670)
api_samr_set_userinfo: Unable to unmarshall SAMR_Q_SET_USERINFO.
[2002/09/30 11:59:24, 0] passdb/pdb_smbpasswd.c:pdb_getsampwrid(1416)
unable to open passdb database.


saludos...Mai


_________________
Mai


  Ver Perfil de Mai   correo electrónico Mai        Editar/Borrar este Mensaje   Responder citando
farleine


Registrados: Sep 30, 2002
Mensajes: 14
Publicado: 2002-10-15 09:27   
Yo no he probado con un XP, pero con el 2000 m encontr en la misma situacin. Solo consegu entrar en el dominio, usando el usuario root y su contrasea. Prueba a ver si t funciona.

Respecto a lo de que t dize k no el equipo no dispone de cuenta en el servidor, prueba a eliminar la cuenta de la maquina en samba y en linux y vuelve a crearlas. Yo te aconsejara, k una vez las hayas borrado, en lugar de crearlas manualmente, aadieses esta linea al fichero smb.conf

add user script = /usr/sbin/useradd -d /dev/null -g 100 -s /bin/false -M %u

De esta manera, cada vez que intentes aadir una mquina al dominio, automticamente crear la cuenta.

Espero haberte ayudado. Aprovecho para pedirte un favor: Yo desde las mquinas windows, si intento conceder privilegios de admin local a usuarios del dominio, los veo a todos, pero solo veo 2 grupos genricos, Domain Users y Domain Admins.
Si tu consigues que salgan todos los grupos del dominio, m podras explicar como lo has hecho? (farleine@yahoo.com)

Talueguen

Toni


  Ver Perfil de farleine      Editar/Borrar este Mensaje   Responder citando
Anónimo
Usuario no registrado
Publicado: 2003-01-10 09:06   
Esto solo funciona para aquellas personas que tiene el problema que en el XP se unen al dominio pero unicamente con la cuenta de ROOT y que al reiniciar el sistema no encuentran el PDC y ademas no pueden loguearse mas que con la cuenta de ROOT, asumiendo que las ligas de confianza y los ususuarios estan creados(Que si gustan lo podemos platicar) solo resta Modificar el Registro de Windoze XP

Tienes que modificar el registro del XP
esto se hace dando INICIO->EJECUTAR->RedEdit

una vez que nos ha abierto la ventana el RED EDIT

BUSCAMOS Y ENTRAMOS A:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters]
EN EL LADO IZQ HASTA QUE DEL LADO DERECHO localcemos EL REGISTRO

"requiresignorseal"=dword:00000001

LE DAMOS DOBLE CLICK Y LE FIJAMOS EL VALOR DE 0 PARA QUE QUEDE COMO:
requiresignorseal"=dword:00000000

Y SRS SAN SE ACABO EL PROBLEMA...

Les mando Saludos al foro, y los invito a que se den una vuelta a nuestro portal Tuxteno.COM (www.tuxteno.com) es un portal referente a Sw libre para usuarios que apenas se inician en todo este mundo de Linux FreeBSD etc... los esperamos espero sus comentarios..


Antonio Karam Mendoza karam@tuxteno.com

} 8 )


     Editar/Borrar este Mensaje   Responder citando
  
Cerrar este Tema Mover este Tema Borrar este Tema