Redes-Linux.com
Esta página esta optimizada para ser visualizada tanto en navegadores gráficos, como en navegadores de texto.
 
Buscar en:


 
El Servidor
Current bandwidth utilization 0.01 Mbit/s
Ancho de banda utilizado
 
Redes-Linux
 
Tip Today by ugu.com
 
Más cosas
 
Conóceme
   [Registrarse]  [Editar Perfil]  [Editar sus Preferencias]  [Buscar]
[Mensajes Privados]  [Lista de miembros]  [preguntas]  [Entrar]
Redes-Linux Forum Index » » Redes en GNU/Linux » » Problema con Servidor DNS
Autor Problema con Servidor DNS
ddiaz427


Registrados: Jan 04, 2010
Mensajes: 1
Publicado: 2010-01-04 22:21   
Hola a todos...

Ando emproblemado con la configuracion de un servidor DNS que no me funciona completamente bien y me gustaria que por favor me colaboraran.

Tengo un servidor con Linux Centos 5.3 en el cual tengo montado el servidor web apache y lo tengo con una ip publica:

http://190.145.21.245/

Ahora bien mi jefe adquirio un dominio para que no se utrilizara la ip como direccion. El proveedor me redirecciono el dominio a mi ip quedando de esta forma:

http://www.gmoas.net/

Pero como podran ver cuando digito la url y me carga la pagina vuelve a cargar la ip.

El proveedor me dijo que configurar un servidor DNS en mi centos para esto y que le diera los DNS primario y secundario para colocarlos en el panel del dominio y pues que el dominio quede funcionando correctamente. Efectivamente eso hice y el dns primario quedo ns1.gmoas.net, pero al colocarlo en el panel dice que el nameserver no es valido. Lo peor es que el serviedor DNS esta fuincionando bien porque si yo coloco esa direccion como dns en alguno de los clientes windows me resuelve los dominios sin problema. No se que estare haciendo mal. Por favor alguien que me pueda colaborar con este dilema, gracias. Visualizo como quedaron los archivos named.conf y los archivos de zona.

[code]

// Red Hat BIND Configuration Tool
//
// Default initial "Caching Only" name server configuration
//

options {
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
forwarders {
200.14.207.210;
200.26.137.135;
};
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
// query-source address * port 53;
};

zone "21.145.190.in-addr.arpa." IN {
type master;
file "21.145.190.db";
};
zone "gmoas.net." IN {
type master;
file "gmoas.net.db";
};


zone "." IN {
type hint;
file "named.root";
};

zone "localdomain." IN {
type master;
file "localdomain.zone";
allow-update { none; };
};

zone "localhost." IN {
type master;
file "localhost.zone";
allow-update { none; };
};

zone "0.0.127.in-addr.arpa." IN {
type master;
file "named.local";
allow-update { none; };
};

zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa." IN {
type master;
file "named.ip6.local";
allow-update { none; };
};

zone "255.in-addr.arpa." IN {
type master;
file "named.broadcast";
allow-update { none; };
};

zone "0.in-addr.arpa." IN {
type master;
file "named.zero";
allow-update { none; };
};
include "/etc/rndc.key";

[/code]

[code]

$TTL 1H
@ SOA ns1.gmoas.net root.ns1.gmoas.net. ( 2
3H
1H
1W 1H )

@ IN NS ns1
ns1 IN A 190.145.21.245
www IN A 190.145.21.245


[/code]

[code]

$TTL 1H
@ SOA ns1.gmoas.net. root.ns1.gmoas.net. ( 2
3H
1H
1W
1H )

@ IN NS gmoas.net.
245 IN PTR ns1
245 IN PTR www


[/code]


  Ver Perfil de ddiaz427      Editar/Borrar este Mensaje   Responder citando
  
Cerrar este Tema Mover este Tema Borrar este Tema