Redes-Linux.com
Esta página esta optimizada para ser visualizada tanto en navegadores gráficos, como en navegadores de texto.
 
Buscar en:


 
El Servidor
Current bandwidth utilization 0.01 Mbit/s
Ancho de banda utilizado
 
Redes-Linux
 
Tip Today by ugu.com
 
Más cosas
 
Conóceme
   [Registrarse]  [Editar Perfil]  [Editar sus Preferencias]  [Buscar]
[Mensajes Privados]  [Lista de miembros]  [preguntas]  [Entrar]
Redes-Linux Forum Index » » Redes en GNU/Linux » » configurar modulo red r8169
Autor configurar modulo red r8169
Anónimo
Usuario no registrado
Publicado: 2004-10-23 12:15   
Necesito ayuda para configurar los parametros del modulo r8169 (SUSE 8.2), sobretodo la velocidad de transmison, pues dicho modulo da soporte al chip (rtl8169s)de una tarjeta ethernet gigabit.

     Editar/Borrar este Mensaje   Responder citando
persono


Registrados: Oct 31, 2003
Mensajes: 585
De: Valencia
Publicado: 2004-10-24 00:15   
Si te lees el README que acompaar a las fuentes del mdulo te dir todo lo que necesitas saber sobre l.
Salud!!
_________________
Creo que me voy a quedar con esta firma:
http://www.sindominio.net/ayuda/preguntas-inteligentes.html


  Ver Perfil de persono   Ir al sitio web de persono        Editar/Borrar este Mensaje   Responder citando
Anónimo
Usuario no registrado
Publicado: 2004-10-26 18:01   
En el fichero readme dice esto
The media can be forced to one of the 5 modes as follows.

Cmd: "insmod r8169 media = SET_MEDIA"
For example:
"insmod r8169 media = 0x04" will force PHY to operate in 100Mpbs Half-duplex.

SET_MEDIA can be:
_10_Half = 0x01
_10_Full = 0x02
_100_Half = 0x04
_100_Full = 0x08
_1000_Full = 0x10


Donde tengo que escribir insmod r8169 media = 0x02

y como lo tengo que hacer





     Editar/Borrar este Mensaje   Responder citando
brias


Registrados: Oct 21, 2003
Mensajes: 692
Publicado: 2004-10-27 09:12   
Bueno...

una vez compilas el mdulo tienes que instalarlo, y esto se hace con insmod.

si te fijas, despus de la compilacin haces un lsmod y no vers tu mdulo, haces el insmo + parmetros, y lo vers...

depus hay que cargarlo cada vez que arrancas y tal.

salu2


  Ver Perfil de brias        Editar/Borrar este Mensaje   Responder citando
Anónimo
Usuario no registrado
Publicado: 2004-10-27 14:38   
El modulo se carga durante el arranque, para hacer la modificacion tengo que desconectarlo o solamente escribir insmod ms parametro desde la consola, pues si es esto ltimo ya lo he hecho (insmod r8169 media = 0x02) y sigo perdiendo paquetes como un condenado porque puede ser ??
Si tengo que desconectarlo como lo hago ??


     Editar/Borrar este Mensaje   Responder citando
persono


Registrados: Oct 31, 2003
Mensajes: 585
De: Valencia
Publicado: 2004-10-27 22:02   
Para que lo haga de forma automtica al arrancar debes editar el fichero /etc/modules.conf (esto puede cambiar dependiendo de tu distribucin, mandrake, red hat y similares es ste, en las de suse, debian, o gentoo, o slackware, no tengo ni idea) y aade la linea "alias eth0 (suponiendo que eth0 es la interfaz de red) r8169 media = 0x02"
Por otro lado, para saber que mdulos tienes cargados "lsmod", para descargar un mdulo "rmmod nombre_modulo".
Suerte!

[ Este Mensaje fue editado por: persono el 2004-10-27 22:02 ]


  Ver Perfil de persono   Ir al sitio web de persono        Editar/Borrar este Mensaje   Responder citando
Anónimo
Usuario no registrado
Publicado: 2004-10-28 13:52   
Existe una nueva version de estos driver, en el readme pone esto

<RTL8169s/8110s Linux kernel driver>

Version: 2.2
Date: 2004-08-09

This is the Linux kernel driver released for
RealTek RTL8169s/8110s Gigabit Ethernet controller.


<Requirements>

- kernel source tree (supported versions 2.4.x or 2.6.x)
- compiler/binutils for kernel compilation



<Quick install with proper kernel settings>

Unpack the tarball :
unzip rtl8169_8110S_linuxdrv_vxx.zip

Change to the directory:
cd rtl8169_8110S_linuxdrv

If you are running the target kernel, then you should be
able to do :

make clean modules (as root or with sudo)
make install
depmod -a

Los pasos que sigo son los siguiente
1 descomprimo
2 escribo make clean modules
3 escribo make install
4 depmod -a
Pero no consigo obtener el r8169.o
y me salen un monton de mensajes de error.
A que puede ser?? lo estoy haciendo bien?? o estoy haciendo alguna burrada (es lo ms probable no)
La pagina de donde me estoy descargando los drivers es esta: http://www.realtek.com.tw/downloads/downloads1-3.aspx?Keyword=rtl8169#2003072Unix%20(Linux)
Podeis hecharle un vistazo y ayudarme.
Gracias



     Editar/Borrar este Mensaje   Responder citando
brias


Registrados: Oct 21, 2003
Mensajes: 692
Publicado: 2004-10-29 08:34   
If you are running the target kernel, then you should be able to do :

Las fuentes del kernel son las mismas de tu kernel actual?

salu2


  Ver Perfil de brias        Editar/Borrar este Mensaje   Responder citando
LEVIATAN


Registrados: Nov 06, 2003
Mensajes: 309
Publicado: 2004-10-29 12:49   
He estado haciendo pruebas con una tarjeta con ese chip, en los kernel 2.6 y a partir de la 2.4.24(creo) de la serie 2.4 ya tiene soporte para estas tarjetas, lo habilite y la tarjeta funcionaba pero el problema q tengo es q cuando hay bastantes accesos el equipo se cuelga, tb puedes compilar directamente el driver, si quieres t lo puedo enviar, tendrs q tener en cuenta el kernel q tienes, x lo q he visto el driver solo ofrece soporte para kernel 2.2.x 2.4.x, bueno, pues eso. Si alguien me puede dar alguna pista de xq se bloquea el equipo, agradeceria cualquier sugerencia.

  Ver Perfil de LEVIATAN      Editar/Borrar este Mensaje   Responder citando
persono


Registrados: Oct 31, 2003
Mensajes: 585
De: Valencia
Publicado: 2004-10-29 13:19   
Has mirado los logs?
Si existe algn problema posiblemente ah te diga que es lo que te sucede.


  Ver Perfil de persono   Ir al sitio web de persono        Editar/Borrar este Mensaje   Responder citando
  
Cerrar este Tema Mover este Tema Borrar este Tema