Redes-Linux.com
Esta página esta optimizada para ser visualizada tanto en navegadores gráficos, como en navegadores de texto.
 
Buscar en:


 
El Servidor
Current bandwidth utilization 0.01 Mbit/s
Ancho de banda utilizado
 
Redes-Linux
 
Tip Today by ugu.com
 
Más cosas
 
Conóceme
   [Registrarse]  [Editar Perfil]  [Editar sus Preferencias]  [Buscar]
[Mensajes Privados]  [Lista de miembros]  [preguntas]  [Entrar]
Redes-Linux Forum Index » » Redes en GNU/Linux » » Cmo marcar con el modem interno
Autor Cmo marcar con el modem interno
perevera


Registrados: Oct 30, 2003
Mensajes: 15
Publicado: 2003-12-06 18:57   
Hola a todos.

Tengo un mdem interno, un Conceptronic 56 PMi, el cual por supuesto funciona bien con Windows XP.

Luego, instal Linux y lo intent configurar. Lo hice desde el Gnome por Configuracin del Sistema -> Red y ah parece que el mdem est correctamente instalado, eso s, como genrico.

El servicio PPP se activa al arrancar y el dispositivo est creado en /dev/ttyS0 como era de esperar. Lo tengo con control de flujo hardware y marcacin por tonos.

Ms cosas: en la configuracin de marcado tengo que se active cuando se inicia el ordenador y que obtenga las direcciones IP automticamente con el marcado, etc. La lista de opciones PPP la tengo vaca.

Configur por supuesto los datos de mi ISP (nmero de telfono, usuario, clave) y como modo de marcado tengo "auto".

Con todo, a m me da que el mdem nunca marca, no intenta realizar la conexin. Supongo que es una tontera, pero no encuentro cmo realizar el marcado manualmente. Imagino que puedo utilizar alguna utilidad (he visto que existe "wvdial" o alguna similar).

Por favor, que alguna mente preclara me ayude a encontrar la tecla justa.


  Ver Perfil de perevera      Editar/Borrar este Mensaje   Responder citando
perevera


Registrados: Oct 30, 2003
Mensajes: 15
Publicado: 2003-12-07 22:37   
Bueno, bueno, ya voy progresando en mis pesquisas.

Ya he visto que 'wvdial' es el programa que usa el sistema para marcar. Lo he ejecutado a mano y me sale que el modem no responde.

Claro, se trata de un winmodem del tipo Conexant HSF 56K HSFi. Como estoy con Red Hat Linux 9 y el kernel es versin 2.4.20-8bigmem, pues dicen que necesitara lo siguiente:

* PCI_56K_V2_K2.2.17.tar.gz

* hsfcompat_24-1.0d.tar.gz

El primero ya me lo he bajado pero el segundo no hay manera de encontrarlo. En todos lados dicen que est en:

http://www.mbsi.ca/hsfcompat/hsfcompat_24-1.0d.tar.gz

pero de ah te manda a la pgina de Linuxant que imagino que lo tiene secuestrado para que pagues por el driver oficial.

Alguien ha instalado estos dos componentes y ha funcionado? Alguien me puede proporcionar ese 'hsfcompat'?

Gracias.


  Ver Perfil de perevera      Editar/Borrar este Mensaje   Responder citando
WEBMAKERMDQ


Registrados: Mar 12, 2004
Mensajes: 86
De: Diseo de sitios web en Mar del Plata
Publicado: 2004-03-12 17:42   
yo tengo el mismo modem pero todavia no encuentro el paquete hsfcompat..., afortunadamente encontre un driver que funciona en Mandrake 9.1 www.linuxant.com . Te baja la veloc. a 14.4 k pero no importa si tenes VMWare como yo, instala Win 95/98 y configura tu modem, yo pude conectarme con win 95 dentro de VMWare y anda a 49 k con intrada (servidor local)

_________________
Espero que sirva mi respuesta...
Si quieren info mia visiten:
http://www.webmakermdq.com.ar


  Ver Perfil de WEBMAKERMDQ   correo electrónico WEBMAKERMDQ   Ir al sitio web de WEBMAKERMDQ          Editar/Borrar este Mensaje   Responder citando
perevera


Registrados: Oct 30, 2003
Mensajes: 15
Publicado: 2004-04-17 00:28   
Al final, consegu bajarme de la pgina de LINUXANT el driver genrico, porque para el kernel que tengo no haba uno especfico:

hsfmodem-6.03.00lnxt04032800full-1.i386.rpm.zip

Lo descomprim e instal con RPM y todo correcto, ahora parece ser que el mdem ya funciona.

Sin embargo, la conexin con mis servidores habituales, Alehop y Telefnica, que en Windows XP me funcionan perfectamente, no van.

Estoy probando con el wvdial, y tengo el siguiente contenido en /etc/wvdial.conf:

[Modem0]
Modem = /dev/ttySHSF0
Baud = 14400
SetVolume = 3
Dial Command = ATDT
Init1 = ATZ
[Dialer Alehop]
Username = alehop@1050
Password = gratis
Phone = 909250250
Inherits = Modem0
[Dialer Telefonica]
Username = telefonicanet@telefonicanet
Password = telefonicanet
Phone = 908200220
Inherits = Modem0

Por otro lado, en /etc/ppp/pap-secrets tengo lo siguiente:

# Secrets for authentication using PAP
# client server secret IP addresses
####### redhat-config-network will overwrite this part!!! (begin) ##########
"alehop@1050" * "gratis"
"telefonicanet@telefonicanet" * "telefonicanet"
####### redhat-config-network will overwrite this part!!! (end) ############

Cuando intento la conexin con Alehop sale esto:

[root@micasa ppp]# wvdial alehop
--> WvDial: Internet dialer version 1.53
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Modem initialized.
--> Sending: ATDT909250250
--> Waiting for carrier.
ATDT909250250
CONNECT 9600
--> Carrier detected. Waiting for prompt.
~[7f]}#@!}!y} }9}"}&} }*} } }#}%B#}%}%}&@[07]>@}'}"}(}"}7A~
--> PPP negotiation detected.
--> Starting pppd at Fri Apr 16 23:44:42 2004
--> pid of pppd: 2124
--> Disconnecting at Fri Apr 16 23:44:45 2004
--> The PPP daemon has died: Authentication error.
--> We failed to authenticate ourselves to the peer.
--> Maybe bad account or password? (exit code = 19)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 19)

Cuando lo intento con Telefnica:

[root@micasa ppp]# wvdial telefonica
--> WvDial: Internet dialer version 1.53
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Modem initialized.
--> Sending: ATDT908200220
--> Waiting for carrier.
ATDT908200220
CONNECT 9600
--> Carrier detected. Waiting for prompt.
Welcome to 3Com Total Control HiPer ARC (TM)
Networks That Go The Distance (TM)
login:
--> Looks like a login prompt.
--> Sending: telefonicanet@telefonicanet
telefonicanet@telefonicanet
Password:
--> Looks like a password prompt.
--> Sending: (password)
~[7f]}#@!}!}!} };}!}$}%j}"}&[7f][7f][7f][7f]}%}&s7}1[19]}1}$}%j}3}#} `[08]~
--> PPP negotiation detected.
--> Starting pppd at Fri Apr 16 23:46:15 2004
--> pid of pppd: 2146

El daemon pppd veo que efectivamente ha arrancado pero el script se queda en este punto eternamente.

Si aado para ambos servidores la opcin "Stupid Mode = 1" la cosa no cambia.

A alguien se le ocurre algn detalle que me falte configurar, o algn parmetro opcional que aadir, ya sea en wvdial o en pppd?
_________________
========
perevera


  Ver Perfil de perevera      Editar/Borrar este Mensaje   Responder citando
Anónimo
Usuario no registrado
Publicado: 2006-06-11 04:20   
Hola, soy usuario de telefonicanet. Lo solucion tras MUCHO buscar aadiendo esto en el archivo /etc/ppp/options

nobsdcomp

nodeflate


Y ya debera tirarte.

Por cierto, recientemente telefonicanet ha cambiado su servidor de dial up y adivinas qu? no me funciona la conexin en linux!! con o sin las opciones esas! Yo mato a alguien jajaja


     Editar/Borrar este Mensaje   Responder citando
perevera


Registrados: Oct 30, 2003
Mensajes: 15
Publicado: 2006-06-13 18:38   
[quote]
El 2006-06-11 04:20, Anonymous escribi:
Hola, soy usuario de telefonicanet. Lo solucion tras MUCHO buscar aadiendo esto en el archivo /etc/ppp/options

nobsdcomp

nodeflate


Y ya debera tirarte.

Por cierto, recientemente telefonicanet ha cambiado su servidor de dial up y adivinas qu? no me funciona la conexin en linux!! con o sin las opciones esas! Yo mato a alguien jajaja
[/quote]

Ostias, qu sorpresa.

Muchas gracias por la respuesta pero, si te fijas, la pregunta data de diciembre del 2003 y, claro, ahora ya tengo ADSL con Jazztel y asunto resuelto.

Un saludo.


  Ver Perfil de perevera      Editar/Borrar este Mensaje   Responder citando
  
Cerrar este Tema Mover este Tema Borrar este Tema